SentryFeed

Security news, read and ranked every 30 minutes.

Vulnerabilities

Exploited. On CISA's list since 2026-09-02.

BerriAI LiteLLM Improper Authentication Vulnerability

CVE-2026-59822 · BerriAI LiteLLM · Published 2026-07-08

How bad would it be?

8.8 out of 10

CVSS rates it high.

How likely is it to be used?

0.8%

Estimated chance of exploitation in the next 30 days, higher than 57% of all scored flaws (EPSS, 2026-10-29).

Is it already being used?

Yes

CISA has seen it exploited in real attacks. For US government agencies the fix is deadline passed 44 days ago (2026-09-16).

What CISA says to do

Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.

BerriAI LiteLLM contains an improper authentication vulnerability in the MCP Streamable HTTP endpoint that could allow an unauthenticated attacker to establish an authenticated MCP session using an arbitrary Bearer token.

What the flaw is

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.84.0, LiteLLM's MCP Streamable HTTP endpoint allowed an unauthenticated attacker to use a fabricated Authorization header to trigger an OAuth2 passthrough fallback path that replaced failed LiteLLM key validation with an empty UserAPIKeyAuth() object, allowing requests to reach MCP tooling without a valid LiteLLM key. This issue is fixed in version 1.84.0.

From the NVD.

Fixes and advisories

Learn this

Explore this week’s weaknesses and all learning topics

Understand the kind of weakness behind this flaw. These resources teach the weakness, rather than reproduce this specific CVE. Follow the vendor's advice above to fix the affected product.

CWE is a catalogue of weakness types. Labels come from the sources shown and can differ or change. Resource matches reviewed 16 October 2026.

On SentryFeed

No story in the last 14 days has mentioned it.

Exploited flaws from CISA's KEV catalogue. Chance of exploitation from EPSS by FIRST. Descriptions and scores from the NVD. This product uses the NVD API but is not endorsed or certified by the NVD.