SentryFeed

Security news, read and ranked every 30 minutes.

Vulnerabilities

Exploited. On CISA's list since 2026-04-16.

Apache ActiveMQ Improper Input Validation Vulnerability

CVE-2026-34197 · Apache ActiveMQ · Published 2026-04-07

How bad would it be?

8.8 out of 10

CVSS rates it high.

How likely is it to be used?

98%

Estimated chance of exploitation in the next 30 days, among the top 1% of all scored flaws (EPSS, 2026-10-29).

Is it already being used?

Yes

CISA has seen it exploited in real attacks. For US government agencies the fix is deadline passed 183 days ago (2026-04-30).

What CISA says to do

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

Apache ActiveMQ contains an improper input validation vulnerability that allows for code injection.

What the flaw is

Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ. Apache ActiveMQ Classic exposes the Jolokia JMX-HTTP bridge at /api/jolokia/ on the web console. The default Jolokia access policy permits exec operations on all ActiveMQ MBeans (org.apache.activemq:*), including BrokerService.addNetworkConnector(String) and BrokerService.addConnector(String). An authenticated attacker can invoke these operations with a crafted discovery URI that triggers the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec(). This issue affects Apache ActiveMQ Broker: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ All: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ: before 5.19.4, from 6.0.0 before 6.2.3. Users are recommended to upgrade to version 5.19.4 or 6.2.3, which fixes the issue

From the NVD.

Fixes and advisories

Learn this

Explore this week’s weaknesses and all learning topics

Understand the kind of weakness behind this flaw. These resources teach the weakness, rather than reproduce this specific CVE. Follow the vendor's advice above to fix the affected product.

CWE-20 · CISA KEV; NVD record: security@apache.org. We have not selected a close learning match for this label.

CWE-94 · CISA KEV; NVD record: security@apache.org. We have not selected a close learning match for this label.

CWE is a catalogue of weakness types. Labels come from the sources shown and can differ or change. Resource matches reviewed 16 October 2026.

On SentryFeed

No story in the last 14 days has mentioned it.

Exploited flaws from CISA's KEV catalogue. Chance of exploitation from EPSS by FIRST. Descriptions and scores from the NVD. This product uses the NVD API but is not endorsed or certified by the NVD.