SentryFeed

Security news, read and ranked every 30 minutes.

Vulnerabilities

Exploited. On CISA's list since 2024-11-07, and used by ransomware.

CyberPanel Incorrect Default Permissions Vulnerability

CVE-2024-51567 · CyberPersons CyberPanel · Published 2024-10-29

How bad would it be?

9.8 out of 10

CVSS rates it critical: about as damaging as flaws get.

How likely is it to be used?

84%

Estimated chance of exploitation in the next 30 days, among the top 1% of all scored flaws (EPSS, 2026-10-29).

Is it already being used?

Yes

CISA has seen it exploited in real attacks. For US government agencies the fix is deadline passed 701 days ago (2024-11-28).

What CISA says to do

Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

CyberPanel contains an incorrect default permissions vulnerability that allows a remote, unauthenticated attacker to execute commands as root.

What the flaw is

upgrademysqlstatus in databases/views.py in CyberPanel (aka Cyber Panel) before 5b08cd6 allows remote attackers to bypass authentication and execute arbitrary commands via /dataBases/upgrademysqlstatus by bypassing secMiddleware (which is only for a POST request) and using shell metacharacters in the statusfile property, as exploited in the wild in October 2024 by PSAUX. Versions through 2.3.6 and (unpatched) 2.3.7 are affected.

From the NVD.

Fixes and advisories

Learn this

Explore this week’s weaknesses and all learning topics

Understand the kind of weakness behind this flaw. These resources teach the weakness, rather than reproduce this specific CVE. Follow the vendor's advice above to fix the affected product.

CWE-276 · CISA KEV. We have not selected a close learning match for this label.

CWE is a catalogue of weakness types. Labels come from the sources shown and can differ or change. Resource matches reviewed 16 October 2026.

On SentryFeed

No story in the last 14 days has mentioned it.

Exploited flaws from CISA's KEV catalogue. Chance of exploitation from EPSS by FIRST. Descriptions and scores from the NVD. This product uses the NVD API but is not endorsed or certified by the NVD.