SentryFeed

Security news, read and ranked every 30 minutes.

Vulnerabilities

Exploited. On CISA's list since 2024-08-27.

Apache OFBiz Incorrect Authorization Vulnerability

CVE-2024-38856 · Apache OFBiz · Published 2024-08-05

How bad would it be?

9.8 out of 10

CVSS rates it critical: about as damaging as flaws get.

How likely is it to be used?

99%

Estimated chance of exploitation in the next 30 days, among the top 1% of all scored flaws (EPSS, 2026-10-29).

Is it already being used?

Yes

CISA has seen it exploited in real attacks. For US government agencies the fix is deadline passed 773 days ago (2024-09-17).

What CISA says to do

Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Apache OFBiz contains an incorrect authorization vulnerability that could allow remote code execution via a Groovy payload in the context of the OFBiz user process by an unauthenticated attacker.

What the flaw is

Incorrect Authorization vulnerability in Apache OFBiz. This issue affects Apache OFBiz: through 18.12.14. Users are recommended to upgrade to version 18.12.15, which fixes the issue. Unauthenticated endpoints could allow execution of screen rendering code of screens if some preconditions are met (such as when the screen definitions don't explicitly check user's permissions because they rely on the configuration of their endpoints).

From the NVD.

Fixes and advisories

Learn this

Explore this week’s weaknesses and all learning topics

Understand the kind of weakness behind this flaw. These resources teach the weakness, rather than reproduce this specific CVE. Follow the vendor's advice above to fix the affected product.

CWE is a catalogue of weakness types. Labels come from the sources shown and can differ or change. Resource matches reviewed 16 October 2026.

On SentryFeed

No story in the last 14 days has mentioned it.

Exploited flaws from CISA's KEV catalogue. Chance of exploitation from EPSS by FIRST. Descriptions and scores from the NVD. This product uses the NVD API but is not endorsed or certified by the NVD.